Takt Employee App Crashing
Resolved·Partial outage

We have identified the cause of the issue affecting the Takt Employee App. Our team has implemented a fix and is monitoring for any further impact.

Tue, Dec 9, 2025, 09:38 PM
(5 days ago)
·
Affected components
Updates

Resolved

We have identified the cause of the issue affecting the Takt Employee App. Our team has implemented a fix and is monitoring for any further impact.

Tue, Dec 9, 2025, 09:38 PM

Identified

We are currently investigating a issue impacting Takt Employee App where devices under Android 12 are unable to launch the app.

Tue, Dec 9, 2025, 09:10 PM(27 minutes earlier)
Powered by

Copyright 2025, Takt, Inc.
Made with ❤️ in Reston, VA