Complete
The maintenance is complete. If you have an issue, please contact support.
In progress
The deployment is out, and we are seeing significantly faster processing times with no errors. We are continuing to monitor the system and will post any updates before the maintenance window closes.
In progress
We are beginning our performance maintenance. During this time, you may see a slight delay in data processing. Following our work, you should see an acceleration of data processing.
Scheduled
To better support our customers during the busiest time, we will perform maintenance on the platform to reduce data processing times and ensure a smooth experience.
Copyright 2025, Takt, Inc.
Made with ❤️ in Reston, VA