Complete
The maintenance is complete. If you have an issue, please contact support.
In progress
All deployments are complete. We are now monitoring the release. We will keep the maintenance window open during the verification period.
In progress
Users should now be able to create Observations. We are now deploying the final components. We will continue to post updates.
In progress
We are aware that users are having issues creating observations. We are working to address the issue.
In progress
Maintenance is progressing as expected. We are continuing to roll out the latest version of the Takt platform and will keep you updated!
In progress
Our team has begun the scheduled maintenance. You may have issues accessing or using Takt during this time. We recommend holding off on critical work until after the maintenance has been completed.
Scheduled
We’ll be performing scheduled maintenance to apply infrastructure updates, security patches, and performance enhancements to ensure the platform continues to run smoothly during the peak season.
Brief service interruptions may occur during this window. We’ll share real-time updates on our Status Page throughout the maintenance period.
Copyright 2025, Takt, Inc.
Made with ❤️ in Reston, VA